Tag Archives: ubuntu

How to update ONLY installed apps in Linux?

When I used Ubuntu recently via VirtualBox an Ubuntu update would keep making the system larger. Finally an update would fail since the VM image size would be exceeded. Attempts to prune temp folders did not help or where excruciatingly geeky.

I noticed that the update would be installing things I never used or thought were part of Ubuntu. I don’t use it much, so have not not delved into the intricacies, i.e., end user. So, my question, is Update really an update?

In Cygwin, for example, when you do an update, you can pick a view, New, Updates, etc. I did not find this capability in the GUI update app. It must be there, it’s supposed to be so much better than Windoze. 🙂

I searched the web for an answer, btw. Look, end-users don’t want to do apt-get and other geek fantasmisms, besides, a lot of the pages I found confuse update of apps with update of the system.

When time allows will give more info as to what I used and some of the things that were being updated.

Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported License.

Ubuntu install in VirtualBox gets compiz error

I tried installing Ubuntu 12.04 into VirtualBox 4.2.4 on a Windows 7 laptop and kept getting graphics errors.

Tried again, but this time after creating the VM and before installing Ubuntu, I set the the graphics settings of the VM (via vb console) to 64mb and 3D. Now it installed. I previously tried Ubuntu 12.10 but gave up. Maybe with this preinstall config change I will try again.

Most of the Linux install on VirtualBox instructions skip any configuration of the VM and go straight into installing the guest OS.

System
Laptop: HP Pavilion dv7, 8GB Ram, quad core i7 CPU, 2.2 GHz. 17″ screen.

Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported License.

Ubuntu 12.04 in VirtualBox 4.2.* on Windows 7

I updated my VirtualBox to 4.2.2. I previously updated Ubuntu to 12.04. Everything is working fine.

My only problem is VirtualBox Guest Additions. I updated it, I think. Or did I? How would I check?
At “how to check version of virtualbox guest additions currently installed…” one of the posts suggests:

lsmod | grep -io vboxguest | xargs modinfo | grep -iw version
version: 4.1.12_Ubuntu

Since I rarely deal with VB installs I never remember the ‘additions’ process.

Update
Oops! You have to install the guest additions in the client Linux OS. After I did this, the VB menu, Machine -> Session Information -> runtime: Guest Additions 4.2.2 r8194.
28 Oct 2012: Updated to VirtualBox 4.2.4 r81684

And the command shows the same:

jbetancourt@jb-vb-acer:~$ lsmod | grep -io vboxguest | xargs modinfo | grep -iw version
version:        4.2.2
Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported License.

Screen capture in Ubuntu running in VirtualBox

Screen capture was not working in a new install of Ubuntu in VirtualBox. The attempts would result in an image of the desktop background. Weird.

Since the default app didn’t work, I installed various other ones. None worked. Finally I installed Gimp. Even that didn’t work.

I think that ruled out an application issue. Left was Ubuntu, Unity desktop, hardware, VirtualBox, or me. Certainly not I.

It was the 3D setting on the virtual machine! Doh! I thought the check box was a request; if the system has no 3D support it would just not use that setting.

Environment
VirtualBox: 4.1.6
Ubuntu: 11.10
Host: Windows 7 64bit

Off topic, but what a great rant! “Why I’ve finally had it with my Linux server and I’m moving back to Windows.” I know the feeling. I had Linux running on an old laptop. Then I tried to upgrade the distro. The laptop stopped working. Now nothing installs, Windoze, other Linux distros, nada. Boot sector issues or firmwear issues. I don’t know. One day I’ll buy an enclosure and try to reuse the laptop harddrive as an external USB backup.

References

 


Bassnectar – Pleasure the Bassnympho


Amy Winehouse – All my lovin’ (The Beatle’s cover)

Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported License.

Network access to VirtualBox VM?

How I set up a new VirtualBox VM running Ubuntu that could be reached from the local network.

I first used the Bridged Network setup, which did not work. This is on VirtualBox 4.1.4. I have other VB vms where the Bridged Networking does work. hmm.

On this VM I changed networking to:
– NAT. Network Address Translation.
– Defined a Port Forward rule (via Virtual Box GUI). Ports on hosting PC get mapped to the VM guest. For example, 22.
– Made sure the Windows 7 Firewall allowed the external port.
– Defined a port forwarding at my network provider.
– Defined a port forward at my local router.

At least, that is what I think I did. In the turmoil of getting things to work, research what others tried, and then success, it is hard to get the actual process just right.

Saved, then waited; takes a while for everything to percolate through the network. Opened the URL and voila, I have access!

That was not easy! Where is that button?

Further reading

  1. VirtualBox Bridged Network Port Forwarding Issue


Bill Evans Trio – Waltz for Debby [Take 2]

Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported License.

VirtualBox 4.1.4 on Windows 7 with Ubuntu guest

Installing over older version was not that hard this time.

First I created snapshots of each VM in my VirtualBox. Next create a restore point for Windows 7, just in case VB destroys stuff.

Then I downloaded and installed the new VirtualBox 4.1.4. It locked up. Went thru some stuff, showed a full taskbar but nothing. No exceptions or suspicious threads in Windows’s Proc Explorer. Install wouldn’t cancel either, had to kill it. Retried but it said there is another install going on. Did not see one in task list.

I rebooted Windows PC. Tried to start the existing Ubuntu VM, but it failed, one of the virtual network drivers is hosed. Shucks. Hmmm. Maybe VirtualBox will install again? This time I right clicked on the downloaded file and choose “Run As Admin”. It installed!

No 3D Unity interface. Guest Additions not updated. Clicked on device menu and install Guest Additions, nada!. I keep forgetting you have to install it manually for a Linux guest. For this I followed the VirtualBox user manual.

First do the steps in 4.2.2.1.1. I ran those using sudo. Second, follow steps in 4.2.2.1. Again using sudo. Shut down VM. In the VirtualBox gui, change the Ubuntu display to 3D. Start Ubuntu VM.

Success, I have the Unity interface again.

Updates

  • On this system I updated to Ubuntu 11.10 (codenamed Oneiric Ocelot). Works fine.

Environment
VirtualBox 4.1.4.
Host: Windows 7 Professional 64bit.
Guest: Ubuntu 11.10 codenamed “Oneiric Ocelot”, Unity desktop.
PC: AMD quad with 8GB ram.
Brain: of carbon-based life form, Earth, Homo sapiens sapiens.


Han Solo and The Princess (Love Theme) from “Empire Jazz”

Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported License.

Rhythmbox on Ubuntu 10.04 won’t play mp3 on NAS

Ah the complexity of computing, no wonder most people only just play games on FaceBook.

Below I describe a problem playing MP3s on a network resource.  I don’t have a solution yet.  And have not at this time (4/24/2010) investigated further.

I installed Ubuntu 10.04 LTS Lucid Lynx in VirtualBox 3.2.2 hosted on Windows 7 Professional 64bit. Rythmbox (the default music software) ver 0.12.8 will play mp3 on the VM’s local file system. However, it won’t play mp3s that are stored on my Networked Attached Storage (NAS), an ancient ReadyNAS (now NetGear) X6 model.

Some observations:

  • If I copy an mp3 from the NAS to the file system, it plays.
  • I can play the same mp3 on the NAS using the Totem Movie Player 2.30.2.

What it could be?

  • Not an access control, since the movie player can play them.
  • Rythmbox has the correct plug-ins, since it can play mp3.
  • It is buggy or some subtle configuration is incorrect when accessing mp3 via network?

Some links
Re: Ubuntu 10.04 – Rhythmbox not working: http://ubuntuforums.org/showthread.php?p=9311110

Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported License.