MercurialEclipse error ‘dotencode’ not supported!

When using Team Mercurial to refresh an Eclipse project I got this error:   “abort: requirement ‘dotencode’ not supported!”

Strange I just updated the Intland Software’s MercurialEclipse feature and it’s running Mercurial 1.7.0.

Fix

Anyway, to fix I just went into the

plug-ins configuration: Windows -> Preferences -> Team -> Mercurial and unchecked the “Use default (built-in) Mercurial executable”.

I specified “C:Program Files (x86)TortoiseHghg.exe” or whatever is the location of the latest hg.

It worked. Hope it doesn’t break something else.

Updates

  • 2011MAR04: I updated to new Hg ver 1.8 and TortoiseHg 2.0. Had to make the change again in Eclipse. TortoiseHg 2.0, btw, looks beautiful. Nice work on the UI.

Further reading

  • https://www.mercurial-scm.org/wiki/RequiresFile
  • http://javaforge.com/project/HGE
  • https://www.mercurial-scm.org/wiki/UpgradingMercurial
  • http://www.jroller.com/andyl/entry/how_open_is_mercurialeclipse


Ralph Towner — Witchitaito

Similar Posts:

Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported License.

10 thoughts on “MercurialEclipse error ‘dotencode’ not supported!”

Leave a Reply

Your email address will not be published. Required fields are marked *