“org.eclipse.search” issue model was not being managed.

I ran a file search (ctrl-h) and got the search results. Double clicked on one of the hits and get an exception in Eclipse. See below.

What I did to fix? Reran the MyEclipse install and chose ‘fix current install’. Then I changed the command line that starts Eclipse to:

“C:\java\MyEclipse 9\myeclipse.exe” -clean -vm C:\java\jdk1.6.0_25\bin\javaw.exe -Xms512m -XX:PermSize=256M -XX:ReservedCodeCacheSize=64m

Haven’t seen the issue today.

Updates
5/9/2011: Still happening.
5/9/2011: Now made a change in the search preferences. Do not reuse editors. Lets see.
5/12/2011: That fixed it. Sounds like a concurrency issue in Eclipse.


org.eclipse.wst.sse.core.internal.util.Assert$AssertionFailedException: release was requested on a model that was not being managed
at org.eclipse.wst.sse.core.internal.util.Assert.isNotNull(Assert.java:124)
at org.eclipse.wst.sse.core.internal.model.ModelManagerImpl.releaseFromEdit(ModelManagerImpl.java:1799)
at org.eclipse.wst.sse.core.internal.model.ModelManagerImpl.releaseFromEdit(ModelManagerImpl.java:1761)
at org.eclipse.wst.sse.core.internal.model.AbstractStructuredModel.releaseFromEdit(AbstractStructuredModel.java:1044)
at org.eclipse.wst.xml.core.internal.document.DOMModelImpl.releaseFromEdit(DOMModelImpl.java:807)
at org.eclipse.wst.html.core.internal.document.DOMStyleModelImpl.releaseFromEdit(DOMStyleModelImpl.java:37)
at org.eclipse.wst.sse.ui.StructuredTextEditor.doSetInput(StructuredTextEditor.java:1849)

eclipse.buildId=unknown
java.version=1.6.0_13
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -Xms512m -XX:PermSize=256M -XX:ReservedCodeCacheSize=64m
Command-line arguments: -os win32 -ws win32 -arch x86 -Xms512m -XX:PermSize=256M -XX:ReservedCodeCacheSize=64m

MyEclipse Version 9.0.

Similar Posts:

Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported License.

One thought on ““org.eclipse.search” issue model was not being managed.”

Leave a Reply

Your email address will not be published. Required fields are marked *